HIT Forums

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Headcrab skin not walking (solved!)  (Read 3523 times)

0 Members and 1 Guest are viewing this topic.

platoon

  • Snark
  • **
  • Offline Offline
  • Posts: 12
    • View Profile
Headcrab skin not walking (solved!)
« on: February 16, 2011, 11:50:34 AM »

Well, now my problem. I've created a headcrab skin (black widow: http://www.moddb.com/mods/platoon/images )
redesigned it for headcrab, The problem is that the model, I don't know why, works as expected  except for the fact that it doesn't walk.
 
If the "headcrab-cockroach" sees me, it turns to me and if I'm in the "jumping distance", it jumps and hurts me.  But if I'm out of range, instead of walking to me and then jumping it just plays constantly the walking (or running, I'm using the same animation for both movements) animation and stays in the same place.

It isn't working Undecided It turns, it jumps, it dies, but it doesn't walk.

used milkshape 3d 1.8.2 (not 3ds max)

also I had to re-import the smd in Milkshape and set keyframe on every frame again (even though the keyframes are already set) but it doesnt fixed my problem

Anyone has any idea of what can be happening?
Thanks a lot!

Code: [Select]
// Output .MDL
$modelname "C:\Documents and Settings\safir\Belgelerim\milkshapes\spider\spidercompile.mdl"

// Directory of .SMD
$cd "\Documents and Settings\safir\Belgelerim\milkshapes\spider\"

// Directory of .BMP
$cdtexture "\Documents and Settings\safir\Belgelerim\milkshapes\spider\"
$cliptotextures

// Write textures into a ???T.mdl
//$externaltextures

$scale 1.0

$bbox -12.000000 -12.000000 0.000000 12.000000 12.000000 24.000000
$cbox 0.000000 0.000000 0.000000 0.000000 0.000000 0.000000
$eyeposition 0.000000 0.000000 20.000000

// bodygroups: use relative path from $cd
$bodygroup body
{
studio "./reference"
}

// sequences: all sequences are in $cd
$sequence idle1 "idle1" loop fps 1 ACT_IDLE 15
$sequence idle2 "idle2" fps 1 ACT_IDLE 1
$sequence idle3 "idle3" fps 1 ACT_IDLE 1
$sequence walk "walk" LX loop fps 4 ACT_WALK 1
$sequence run "run" LX loop fps 13 ACT_RUN 1
$sequence angry "angry" loop fps 3
$sequence flinch "flinch" fps 4 ACT_SMALL_FLINCH 1
$sequence dieback "dieback" fps 6 ACT_DIESIMPLE 1
$sequence 180_left "180_left" loop fps 6 ACT_TURN_LEFT 1
$sequence 180_right "180_right" loop fps 6 ACT_TURN_RIGHT 1
$sequence jump "jump" fps 6 ACT_RANGE_ATTACK1 2 { event 2 0 }
$sequence jump_variation1 "jump_variation1" fps 5 ACT_RANGE_ATTACK1 1 { event 2 0 }
$sequence jump_variation2 "jump_variation2" fps 7 ACT_RANGE_ATTACK1 1 { event 2 0 }
$sequence yaw_adjustment "yaw_adjustment" loop fps 30 ACT_MELEE_ATTACK2 1
$sequence headcrabbed#1 "headcrabbed#1" fps 20 { event 1000 1 } { event 1003 110 "splat" } { event 1 109 }
$sequence headcrabbed#2 "headcrabbed#2" fps 20 { event 1000 1 } { event 1 165 }
$sequence headidle "headidle" loop fps 18
$sequence crashidle "crashidle" loop fps 34
$sequence crash "crash" fps 20 { event 1000 1 }
$sequence hstruggleidle "hstruggleidle" loop fps 18
$sequence hstruggle "hstruggle" fps 28 { event 1000 1 }
« Last Edit: February 16, 2011, 02:33:28 PM by platoon »
Logged

bloodsurfer

  • The zxeno prophet
  • Gargantua
  • *******
  • Offline Offline
  • Posts: 521
  • Coding furiously
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #1 on: February 16, 2011, 12:20:37 PM »

I guess the walking animation is custom ?
Is your animation going forward in milkshape ?
Logged

platoon

  • Snark
  • **
  • Offline Offline
  • Posts: 12
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #2 on: February 16, 2011, 12:50:18 PM »

i redesigned all animations (but same options for headcrab, same names) so its custom yes

walking animation is fine in milkshape and there is no problem with hl model viewer too
but in game it just play walk animation but it doesn't move (move and run animations same)

also I'm tried change idle animation with walk animation, so it make idle animation and still doesn't move
Logged

bloodsurfer

  • The zxeno prophet
  • Gargantua
  • *******
  • Offline Offline
  • Posts: 521
  • Coding furiously
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #3 on: February 16, 2011, 01:40:31 PM »

i redesigned all animations (but same options for headcrab, same names) so its custom yes

walking animation is fine in milkshape and there is no problem with hl model viewer too
but in game it just play walk animation but it doesn't move (move and run animations same)

also I'm tried change idle animation with walk animation, so it make idle animation and still doesn't move
The animation name doesn't matter for the headcrab for the animations with ACT_XXX in the QC file
I'm not sure you understood me with the going forward question, post your anim here I'll check it myself
Logged

platoon

  • Snark
  • **
  • Offline Offline
  • Posts: 12
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #4 on: February 16, 2011, 01:47:15 PM »

i sent it with pm
Logged

bloodsurfer

  • The zxeno prophet
  • Gargantua
  • *******
  • Offline Offline
  • Posts: 521
  • Coding furiously
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #5 on: February 16, 2011, 02:06:14 PM »

Exacly what I though, the walking anim isn't going forward in milkshape ence the model not moving ingame, check the orignal headcrab AI's model (here) to see what I mean
Logged

platoon

  • Snark
  • **
  • Offline Offline
  • Posts: 12
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #6 on: February 16, 2011, 02:13:00 PM »

aha i understand now it need to move forward to move in game...
and the last question, that moving forward speed effect monster move speed? or i need modify it in qc frames?
Logged

bloodsurfer

  • The zxeno prophet
  • Gargantua
  • *******
  • Offline Offline
  • Posts: 521
  • Coding furiously
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #7 on: February 16, 2011, 02:18:04 PM »

Acutaly both count, the distance wich the anim is going forward in milkshape will be travled by the time the anim is over in game, if you get the fps value higher in the QC (for the run anim I guess) then the monster will travel faster, don't make the anim going to far trough overwhise the monster won't be able to make smooth turn
Logged

platoon

  • Snark
  • **
  • Offline Offline
  • Posts: 12
    • View Profile
Re: Headcrab skin not walking (again same problem)
« Reply #8 on: February 16, 2011, 02:27:56 PM »

thank you very much bloodsurfer really..
Logged

bloodsurfer

  • The zxeno prophet
  • Gargantua
  • *******
  • Offline Offline
  • Posts: 521
  • Coding furiously
    • View Profile
Re: Headcrab skin not walking (solved!)
« Reply #9 on: February 16, 2011, 02:43:28 PM »

No problem, don't exitate to ask again, I go by the name of The Zxeno Prophet on ModDB and HLC btw
Logged