HIT Forums

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Couple of bugs  (Read 6832 times)

0 Members and 1 Guest are viewing this topic.

Android

  • Alien Grunt
  • ******
  • Offline Offline
  • Posts: 280
    • View Profile
Couple of bugs
« on: September 29, 2005, 02:59:14 AM »

Texture bug ive encountered. First pic: Scientists glasses are opaque. Second Pic: Scientists glass are additive when flashlight is shown on them.

[File not found]
Logged

halflifedave

  • Converter
  • Gonarch
  • ********
  • Offline Offline
  • Posts: 1164
  • Greed
    • View Profile
Re: Couple of bugs
« Reply #1 on: September 29, 2005, 03:20:43 AM »

WHAT THE....IS THE BETA OUT  >:(

even more off topic: I hate how flashlights make everything look ass-ugly on Source  :-\

I can't help ya for Source either way sry  :D
Logged

Android

  • Alien Grunt
  • ******
  • Offline Offline
  • Posts: 280
    • View Profile
Re: Couple of bugs
« Reply #2 on: September 29, 2005, 03:28:02 AM »

No betas not out. I told frrakssured i was going to post these screen shots, thing ive noticed is that the flashlight makes additive textures opaque, and opaque textures additive, depends on the opaque texture though, like the scientists glasses up there
Logged

Frraksurred

  • Team HL:S:HD
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1822
  • ~ More Hi-Deffier ~
    • View Profile
    • World Wide Ambassadors
Re: Couple of bugs
« Reply #3 on: September 29, 2005, 05:02:54 AM »

I believe those are the PS2 Scientists.  We are using A.I's improved PS2 Scientist.

I don't believe it has that problem.  ;D
Logged

flynia

  • HLS-HD Team Member
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1298
  • EliTe HeAdCrAb!!!
    • View Profile
Re: Couple of bugs
« Reply #4 on: September 29, 2005, 05:06:37 AM »

I have that problem with the glasses as well

Can we have the code posted from your "sceintist_glasses_lens_chrome.vmt" if possible?

Cheers flynia
Logged

Frraksurred

  • Team HL:S:HD
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1822
  • ~ More Hi-Deffier ~
    • View Profile
    • World Wide Ambassadors
Re: Couple of bugs
« Reply #5 on: September 29, 2005, 05:26:03 AM »

This is what I have, tell me if it matches yours or not.

"VertexLitGeneric"
{
   "$envmap" "models/scientist/scientists_glasses_lens_chrome"

   "$detail" "detail/detail_noise1"

   "$detailscale" 2.5

   "$translucent" 1

   "$alpha" 1

   "$vertexalpha" "1"

   "$no_fullbright" "1"

   "$nodecal" "1"

   "$surfaceprop" "metal"
}


EDIT:  You're right, mine is doing it to, though it is white opaque, not black.  Curious I never noticed it before.  I'll have to compare this with the hgrunt .vmt to see how the gasmask handles transparency.  It may just be the lense texture.

Thanks for the heads up Android, this is the kind of constructive feedback we need.  We appreciate your help, keep up the good work.
« Last Edit: September 29, 2005, 05:34:01 AM by Frraksurred »
Logged

Romka™

  • I am
  • Gonarch
  • ********
  • Offline Offline
  • Posts: 2543
    • View Profile
Re: Couple of bugs
« Reply #6 on: September 29, 2005, 05:27:33 AM »

This is what I have, tell me if it matches yours or not.

"VertexLitGeneric"
{
   "$envmap" "models/scientist/scientists_glasses_lens_chrome"

   "$detail" "detail/detail_noise1"

   "$detailscale" 2.5

   "$translucent" 1

   "$alpha" 1

   "$vertexalpha" "1"

   "$no_fullbright" "1"

   "$nodecal" "1"

   "$surfaceprop" "metal"
}

Who made this vmt? . . . many things are just useless.

Damn, I've got to go to school in 3 minutes.
Logged

Frraksurred

  • Team HL:S:HD
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1822
  • ~ More Hi-Deffier ~
    • View Profile
    • World Wide Ambassadors
Re: Couple of bugs
« Reply #7 on: September 29, 2005, 05:33:30 AM »

Who made this vmt? . . . many things are just useless.

I believe I got it from Barneyinblue.
Logged

flynia

  • HLS-HD Team Member
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1298
  • EliTe HeAdCrAb!!!
    • View Profile
Re: Couple of bugs
« Reply #8 on: September 29, 2005, 06:04:03 AM »

Ahh Ha! Managed to fix the bug by including a Alpha Chanel and removing 90% of the VMT file details :)

Frrakk ive emailed you the files. These will need to go into the /models/scientist directory



Cheers flynia
« Last Edit: September 29, 2005, 10:59:57 AM by flynia »
Logged

Barnz

  • French Fries
  • Gonarch
  • ********
  • Offline Offline
  • Posts: 1420
    • View Profile
Re: Couple of bugs
« Reply #9 on: September 29, 2005, 11:09:31 AM »

Who made this vmt? . . . many things are just useless.

Damn, I've got to go to school in 3 minutes.

Lol, I made that *.vmt file 9 months ago. Now I know much more about Source Engine.
Logged

Frraksurred

  • Team HL:S:HD
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1822
  • ~ More Hi-Deffier ~
    • View Profile
    • World Wide Ambassadors
Re: Couple of bugs
« Reply #10 on: September 29, 2005, 12:59:09 PM »

Excellent, looks much better.  Thanks for the files Flynia.

Yeah, I've been learning at a steady pace to.  Still have a long way to go!  ;D
Logged

flynia

  • HLS-HD Team Member
  • Moderator
  • Gonarch
  • *******
  • Offline Offline
  • Posts: 1298
  • EliTe HeAdCrAb!!!
    • View Profile
Re: Couple of bugs
« Reply #11 on: September 30, 2005, 03:54:16 AM »

The following file will be necessary as it includes a new texture file that you will need.

First off delete the exisitng "scientist" directory from:

"C:\xxx\Steam\SteamApps\<username>\half-life source\hl1\materials\models\"

Then extract the RAR file from:

http://files.filefront.com/scientistrar/;11623694;/fileinfo.html

Into your:

"C:\xxx\Steam\SteamApps\<username>\half-life source\hl1\materials\models\" directory

I have closed this topic as the bug has been resolved :) :) :)

Cheers flynia
« Last Edit: August 27, 2008, 10:08:40 PM by Frraksurred »
Logged