HIT Forums

Please login or register.

Login with username, password and session length
Advanced search  

Author Topic: Failed to create D3D device  (Read 4380 times)

0 Members and 1 Guest are viewing this topic.

Morpheus

  • =P
  • I can't upload no mores :(
  • Alien Grunt
  • *
  • Offline Offline
  • Posts: 301
  • Heeehhh...
    • View Profile
Failed to create D3D device
« on: July 29, 2008, 12:15:21 AM »

So, everytime I try to launch a source game or doom III, It says that it failed to create the D3D device, Steam, Dell, neither has helped me. I had to run my comp in VGA mode to disable something, and it never got back. My graphics card is an nVidia GeForce GO7400. Can anyone help.
Logged

Frostbite

  • Today I've molested a...
  • Gonarch
  • ********
  • Offline Offline
  • Posts: 2466
  • Can't shake this feeling.
    • View Profile
    • Frostbite
Re: Failed to create D3D device
« Reply #1 on: July 29, 2008, 12:22:03 AM »

So wait did it work before you disabled VGA?

And tried updating drivers?
Logged

Morpheus

  • =P
  • I can't upload no mores :(
  • Alien Grunt
  • *
  • Offline Offline
  • Posts: 301
  • Heeehhh...
    • View Profile
Re: Failed to create D3D device
« Reply #2 on: July 29, 2008, 02:22:34 AM »

I tried the driver update, and yes, it worked before. I accidentally jacked up the contrast on the nVidia panel and moved the mouse and couldnt find the button to set it back, so dell said to boot my computer in VGA mode, now all my GoldSrc games run in low res and Source games wont run at all.
Logged

Frostbite

  • Today I've molested a...
  • Gonarch
  • ********
  • Offline Offline
  • Posts: 2466
  • Can't shake this feeling.
    • View Profile
    • Frostbite
Re: Failed to create D3D device
« Reply #3 on: July 29, 2008, 02:53:40 AM »

Startup Tips

Basically get to advanced startup screen and you should be able to disable VGA.
Logged

Morpheus

  • =P
  • I can't upload no mores :(
  • Alien Grunt
  • *
  • Offline Offline
  • Posts: 301
  • Heeehhh...
    • View Profile
Re: Failed to create D3D device
« Reply #4 on: July 29, 2008, 04:54:55 AM »

I tried it, but couldn't find a way to disable VGA mode/
Logged

random salad

  • DANCING SOCKS
  • Gargantua
  • *******
  • Offline Offline
  • Posts: 769
  • WITH UNOFFICIAL SUPERSPECIAL NOPERMISSION TO SPAM
    • View Profile
Re: Failed to create D3D device
« Reply #5 on: July 29, 2008, 07:38:42 AM »

You should install the latest graphics drivers for your card once you get things back to how things were (When you were still having the D3D problem, rather than low-res issues).

I don't know why you chose to fiddle with VGA mode, but by the sound of it, it's some kind of fallback driver solution, yes? All that's happened by the sound of things is that you're not using the real drivers for your card but instead the default VGA drivers, which means you don't have any hardware acceleration.

Go to nvidia.com, download and install the latest drivers for your card and OS, and see if you can disable VGA mode after that.
Logged

User with the dancing badger

  • HIT's Resident Programmer.
  • Gonarch
  • ********
  • Offline Offline
  • Posts: 1267
  • ~= Master Of Mess =~
    • View Profile
    • HostileZone
Re: Failed to create D3D device
« Reply #6 on: July 29, 2008, 05:20:39 PM »

Do you have the DirectX SDK installed ? If so go to the DX control panel (Start>Programs>MS DirectX SDK>DirectX Utilities>DirectX Control Panel) and try swapping to debug mode. (Top right.) My laptop needs this for some reason.
Logged

Morpheus

  • =P
  • I can't upload no mores :(
  • Alien Grunt
  • *
  • Offline Offline
  • Posts: 301
  • Heeehhh...
    • View Profile
Re: Failed to create D3D device
« Reply #7 on: July 30, 2008, 04:35:28 AM »

Tried using the driver update, but didn't work. I don't have DirectX SDK.
Logged